IoTって泣いている顔のように見えるのです。なのでcryをつけて「Iotcry」です。
hpのスイッチを設定しよう。h3cコマンド体系の一覧をciscoと比較してみた。 | インターネット、IoT関連のお悩み解決

hpのスイッチを設定しよう。h3cコマンド体系の一覧をciscoと比較してみた。

HPのスイッチ設定。

cisco機器より比較的価格が安く、また購入すると5年間のライフタイム保証がデフォルトで付いてくるので特に海外では人気の機種です。

しかしながら設定するにあたってはコマンド体系がciscoとは異なる。

以下にまとめてみましたのでご参考になれば倖いです。

  

hpのスイッチを設定しよう。h3cコマンド体系の一覧をciscoと比較してみた。

以下にcisco機器のコマンドとの比較の形で表にまとめてみました。

役割 cisco h3c(HP)
コンフィグ投入モードへ移行 configure terminal system-view
終了 exit quit
ホスト名設定 hostname sysname
バージョン確認 show version display version
running config確認 show running-config display current-configuration
startup config確認 show startup-config display saved-configuration
インターフェース一覧確認 show ip interface brief display ip interface brief
インターフェースステータス確認 show interface status display brief interface
設定削除 no `設定値` undo `設定値`
再起動 reload reboot
設定保存 copy running-config startup-config または write memory save
サポート情報取得 show tech-support password display diagnostic-information
設定初期化 erase startup-config reset saved-configuration
シリアル番号の確認 show version,show hardware,show inventory,show module dis device manuinfo
vlan確認 show vlan display vlan
ポートチャネル、リンクアグリケーション確認 show etherchannel summary show lacp や show trunk
デフォルトルート ip route 0.0.0.0 0.0.0.0 [nexthop] ip route-static 0.0.0.0 0.0.0.0 [nexthop]
NTP設定 ntp server [ntp server] ntp-service unicast-server [ntp server]
telnet設定 line vty 0 4 [enter] password [パスワード文字列] [enter] login [enter] telnet server enable
timezone設定(日本時間の場合) clock timezone JST 9 clock timezone #Web#9#01 add 09:00:00
コンフィグのバックアップ(管理PCなどでtftpサーバの起動が条件) copy startup-config tftp:[IPアドレス]/コンフィグファイル名 tftp [IPアドレス] put flash:/config.cfg sw名_config.cfg
コンフィグのリストア(管理PCなどでtftpサーバの起動が条件) copy tftp:[IPアドレス]/コンフィグファイル名 startup-config tftp IPアドレス get sw名_config.cfg flash:/config.cfg
MAC テーブルの確認 show arp display mac-address dynamic
電源の状態確認 show env all display power
ファンの状態確認 show env all display fan

※HPでsaveコマンドを実行してコンフィグ保存するときは確認メッセージを聞いてきますが「y」エンターエンターで既存コンフィグを上書きしちゃいます、僕は。

表にまとめるのが難しかったので以下、個別に記載します。

コンソールパスワード設定

★ciscoの場合

line console 0
password [パスワード文字列] login
exit

★h3cの場合

user-interface vty 0
authentication-mode password
set authentication password simple [パスワード文字列] quit

スポンサーリンク

vlan作成、設定

★ciscoの場合

interface vlan xx
ip address xx.xx.xx.xx xx.xx.xx.xx
no shut
exit

★h3cの場合

vlan xx
name xxx
port xxx
quit

interface Vlan-interfacexxx
ip address xx.xx.xx.xx xx.xx.xx.xx

ポートに割り当てます。

access(untag)の場合は

interface 該当インタフェースxx
port link-type access
port access vlan xxx
quit

trunk(802.1q)の場合は

interface 該当インタフェースxx
port link-type trunk
port trunk permit vlan all
quit

ポートチャネル、リンクアグリケーションの設定

vlanはtrunkで設定してみます。vlan1は使いたくないので削除。

★ciscoの場合

interface port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20
exit

束ねたいポート全てに下記設定を入れます。ciscoはポートチャネルのモードが3種類ありますので対向機器とモード設定を合わせる必要があります。

interface 該当の物理インタフェース○○
channel-group 1 mode [(active / passive) / (desirable / auto) / on] no shutdown
exit

★h3cの場合

interface Bridge-Aggregation○○
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan xx yy zz ○○ ・・・
quit

束ねたいポート全てに下記設定を入れます。

interface 該当の物理インタフェース○○
port link-mode bridge
description ### ポートの説明をここに入れます ###【説明文は任意】
port link-aggregation group 1
quit

スタッキング設定

★ciscoの場合
スタックケーブルをスタックポートにたすき状に1号機のポート1を2号機の2に,というように接続すればOK

確認コマンドは

show switch

マスターのスイッチに「*」が表示される。
Current Stateは「Ready」かな。「initialize」だとまだスタックが構成されてません。

★h3cの場合

irfという、普通のLANインタフェースなどをスタック用に設定する仕組みを使います(バーチャルスタック)
ここではGigabitEthernet1/0/47 ~ 48 を設定します。

1.まずは、irfで利用するポートをshutdown
interface GigabitEthernet1/0/47
shutdown
interface GigabitEthernet1/0/48
shutdown

2.”1″をマスターにするために優先度を設定
irf member 1 priority 10

3.該当ポートをグループメンバーに登録する
irf-port 1/2
port group interface GigabitEthernet1/0/47 mode normal
port group interface GigabitEthernet1/0/48 mode normal

4.irfをアクティブ化する
irf-port-configuration active

5.2台目のスタックのスレーブになるスイッチを設定する
irf member 1 renumber 2 <-スイッチボックス番号(ID)を変更 quit reboot 6.該当のインタフェースをshutdownする interface GigabitEthernet2/0/47 shutdown interface GigabitEthernet2/0/48 shutdown 7.irfのグループ2で作成する irf-port 2/1 <-これを1/2とかにするとおかしくなるので注意 port group interface GigabitEthernet2/0/47 mode normal port group interface GigabitEthernet2/0/48 mode normal 8.ポートを開放する interface GigabitEther2/0/47 undo shutdown interface GigabitEther2/0/48 undo shutdown 9.最後にirfをactiveにする irf-port-configuration active 確認コマンドは

display irf
display irf configuration

ミラーポートの設定

★ciscoの場合

monitor session 1 source interface [ミラー元のポート] monitor session 1 destination interface [出力先のポート]

★h3cの場合

mirroring-group 1 mirroring-port [ミラー元のポート] [出力先のポート] both

ミラーポートの設定内容を確認する

 display mirroring-group all

snmpの設定

★ciscoの場合

access-list 1 permit host [SNMPサーバIP] snmp-server community [コミュニティ名] rw 1
snmp-server host [SNMPサーバIP] version 2c [コミュニティ名] snmp-server enable traps

★h3cの場合

snmp-agent
snmp-agent community write [コミュニティ名] snmp-agent sys-info version all
snmp-agent target-host trap address udp-domain [SNMPサーバのIP] params securityname [コミュニティ名]

syslogの設定

★ciscoの場合

logging host [syslog server ip]

★h3cの場合

info-center loghost [syslog server ip] facility local0

acl,名前付き拡張アクセスリストの設定

★ciscoの場合

名前付きアクセスリストの作成
ip access-list extended [アクセスリスト名]

アクセスリストへルールを投入
permit ip source [元IP] [元サブネット] [宛先IP] [宛先サブネット] ※IPのサブネットがhostの場合はIPの前に「host」と入力します。またはサブネットに「255.255.255.255」を入力。

permit tcp source [元IP] [元サブネット] eq [元ポート] [宛先IP] [宛先サブネット] eq [宛先ポート]

 ルールを途中に挿入したい場合は
show access-list
で既存のルール番号を確認した後、投入したいルールの頭に適切なフィルター番号を投入します。

(例)

show access-list
ip access-list extended testacl
10 deny 10.0.0.0 0.255.255.255 any
20 permit ip any any
exit

に追加
ip access-list extended testacl
15 deny 192.168.0.0 0.0.255.255 any
とすると
ip access-list extended testacl
10 deny 10.0.0.0 0.255.255.255 any
15 deny 192.168.0.0 0.0.255.255 any
20 permit ip any any
exit

 
 になります。

★h3cの場合

名前付きアクセスリストの作成
acl advanced name [アクセスリスト名]

アクセスリストへルールを投入
rule permit ip source [元IP] [元サブネット] destination [宛先IP] [宛先サブネット] ※IPのサブネットがhostの場合は「0」と入力します。

rule permit tcp source [元IP] [元サブネット] source-port eq [元ポート] destination [宛先IP] [宛先サブネット] destination-port eq [宛先ポート]

 ルールにはcisco同様番号が付与されています。H3Cの場合はコンフィグに番号が表示されるので既存ルールの間に新規ルールを挿入する場合は間に挿入できるような適切な番号を「rule」の後に記述します。

hpのスイッチを設定しよう。h3cコマンド体系の一覧をciscoと比較してみた。~結論~

HPのスイッチのコマンドを一覧でまとめてciscoのコマンドと比較してみました。HPのスイッチといいつつ、NECさんもOEMで販売していたります。

HPのスイッチは購入した時点で5年間のライフタイム保証(故障時のスイッチ交換)が付いているので良いですね^^
※なおHPの正式名称はトップ画像のHitPointではありません、正式名称はヒューレッドパッカードですね。念のため。

本記事がみなさまのご参考になれば倖いです。最後まで読んでいただきありがとうございました。

別記事もご参照ください。

スポンサーリンク
  • このエントリーをはてなブックマークに追加
関連コンテンツ(レシポンシブル)




 

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

%d人のブロガーが「いいね」をつけました。